UFS-922 FRITZ.NAS Erkennung schlägt fehl

      UFS-922 FRITZ.NAS Erkennung schlägt fehl

      In dem Dokument "UFS 922/912 si/sw UFC 960sw Mediacenter und Netzwerk(Web)-Interface" ( kathrein.de/esc-kathrein/data/…anleitung_mediacenter.pdf ) wird super beschrieben, welche Netzwerkfunktionen wie funktionieren sollten und einzurichten sind. Die Informationen über die Verwendung eines über ein NAS bereitgestellten File-Share als Aufnahmeziel sind zwar etwas zwischen den Zeilen (S. 23ff) aber im Prinzip ist alles erläutert.

      Mein Problem ist, dass keiner meiner vier UFS-922 (alle FW v2.3) mein FRITZ.NAS erkennt. Im Unter "Media" wird es zwar als UPnP Server erkannt, aber im EPG erscheint der File-Share nie als Aufnahme-Ziel. Bei der Einstellung des NAS als (wie auf S. 32 kurz beschrieben) kann man ohnehin jede Adresse und jeden Pfad eingeben. Eine Überprüfung der Gültigkeit der Daten findet nicht statt. Daher erhält man auch keinen Hinweis, ob hier ggf. ein anderes Format verlangt werden würde.

      Nach bestem Wissen und Gewissen habe ich Die Daten so konfiguriert, wie es die Beispiele nahelegen (z.B. IP-Adresse ohne "\\" voran, und der File-Share-Pfad-Name mit "/" statt "\"). User und Passwort habe ich auch eingetragen, Wake on LAN nicht konfiguriert (auch keine MAC). Andere Rechner im Netzwerk können mit den verwendeten Daten problemlos auf das File-Share zugreifen, der/die UFS-922 sehen es leider nicht.

      Es ist mir auch nicht ganz klar, ob ich noch irgendwo am NAS den Port für die File-Share-Freigabe konfigurieren muss. Im Synology-Beispiel sieht man die Verwendung des Port 5000, leider habe ich keine Ahnung, ob das der Standard-Port ist und wenn ja (oder auch nein) wo ich den in meiner Fritz-Box 7270 ändere (gehört aber nicht hierher).

      Vielen Dank für jeglichen Hinweis!
      Hallo crazystone

      Das Probleme das du hast liegt vermutlich an deiner Fritzbox, und nicht an deiner Kathi und auch nicht an deiner NAS. Das die Fritzbox der Schuldige ist habe ich hier oder in einem anderen Forum gelesen.
      Die Verwendung eines Gigabit-Switch soll dieses Problem lösen. Also den Gigabit-Switch an die Fritzbox und alle andere Geräte die auf die NAS zugreifen sollen an den Gigabit-Switch anschließen.


      Tschau und Grüße, Frank. :hi
      Kathrein UFS 922 1TB WD10EVDS FW 2.07
      TechniSat HD S2 (ohne Plus) 1TB WD10EVDS
      Kathrein UFS 913 ext. HDD 500 GB FW 1.05
      Kathrein UFS 913 ext. HDD 500 GB FW 2.00
      LG 37LH4900 TV
      Pan DVD Rec DMR-EH65
      Pio DVD Rec DVR-5100H
      WD TV Live Mediaplayer

      UFS-922 FRITZ.NAS Erkennung

      Hallo nochmals,

      also dank eines älteren Beitrags von Rex Kramer (DAANKEE!!) bin ich einen großen Schritt weiter. Mit den Einstellungen:

      Name: FRITZ.NAS [bin nicht sicher, wie wichtig das ist]
      IP und Freigabeordner: 192.168.178.20/FRITZ.NAS [wobei min. die IP-Adresse in anderen Netzen natürlich anzupassen ist]
      NAS-Benutzername: FRITZ.NAS [eben exakt der Name der Freigabe]
      NAS-Passwort: [nix eingegeben]
      Wake on Lan für NAS: [Kein Haken gesetzt]
      NAS MAC-Adresse: [nix eingegeben]
      Port: [nix eingegeben]

      und in der Fritz!Box --> Heimnetz --> Speicher (NAS) --> Sicherheit --> keinen Kennwortschutz aktiv, lesen + schreiben
      (Achtung! damit ist natürlich das File-Share im gesamten Heimnetz auch sichtbar und les- und schreibbar!)
      hat es nach tagelangen ergebnislosen Versuchen endlich funktioniert, dass ich im UFS-922 EPG als Aufnahmeziel das heiß begehrte "/mnt/cifs/0" sehe. Eine Aufnahme dahin hat dann auch funktioniert, nachdem UFS-922 selbst die Ordner kathrein/records angelegt hat.

      Der Schlüssel scheint der Benutzername zu sein, der identisch mit der Freigabe im NAS sein muss.

      Damit ist mir allerdings nur teilweise geholfen, da jeder Versuch einen Benutzer mit längeren / tieferen Pfadnamen (also Namen mit "/") anzugeben und ggf. Unterverzeichnisse oder symbolische Links zu verwenden, fehlgeschlagen sind. Direkt unter der NAS-Freigabe FRITZ.NAS hat die Fritz!Box leider nur einen internen Speicher von ein paar MB, was Filmaufnahmen komplett selbst verbietet. Da hilft die an der Fritz!Box hängende 1TB Platte nichts, weil die eben in einem Unterverzeichnis ansprechbar ist und freigegeben wird, was ich aber über die Freigabe-Ordner vs. Benutzernamen Logik des UFS-922 nicht konfigurieren kann (jedenfalls habe ich es nicht geschafft).

      Wenn also noch jemand die komplette Logik und die Beschränkungen hinter der

      Name:
      IP und Freigabeordner:
      NAS-Benutzername:

      Orgie versteht, jemand von Kathrein sich das vielleicht mal im FW Source-Code anschauen kann, wäre ich sehr dankbar!

      Vielleicht gibt es ja doch noch einen Workaround!

      Danke im Voraus!

      UFS-922 NAS Erkennung

      Noch zwei Nachträge:
      Beim ersten Mal, wenn man es richtig konfiguriert, muss man immer noch im EPG zweimal das Fenster "Ziel: Aufnahme-Archiv" öffnen, bevor das "/mnt/cifs/0" erscheint. Es ist dann erst noch ausgegraut, man kann es aber trotzdem zur Aufnahme anwählen (wahrscheinlich Dauer der Initialisierung). Beim zweiten Mal wird es dann sofort (auch nicht mehr ausgegraut) erkannt.
      Im Rahmen der verzweifelten Versuche, im Benutzernamen einen Pfad zu verstecken, habe ich es geschafft, den UFS-922 (FW 2.03) komplett abzuschießen. Gibt man beim Benutzernamen "NAS%47#SAMSUNG-HD103UI-01" im Netzwerk-Interface ein, so wird beim Abspeichern der UFS-922 komplett abgeschaltet :ahm Ob das so gewollt war?!
      Ich werde mal weiterfummeln...
      Ich weiss, es gehört vielleicht nicht hierher, aber ich versuche nun gerade meiner Fritz!Box beizubringen, die extern angeschlossene Festplatte unter dem Namen "kathrein\" zu mounten.

      Dazu ein wichtiger Hinweis: An der Fritz!Box kann man den Telnet-Dienst einschalten, indem man am Telefon #96*7* wählt. Echt unglaublich! Damit kommt man dann an das root-Verzeichnis und kann in den Linux Einstellungen rumfuhrwerken.

      Ich fummle mal weiter...
      Also nochmals in der Zusammenfassung:
      Am UFS-922 Netzwerkinterface folgende Einstellungen vornehmen:
      Name: NAS [ist glaube ich egal, habe aber immer denselben Namen gewählt, wie die Fritz!Box Freigabe]
      IP und Freigabename: 192.168.178.1/NAS [hier ist alles wichtig, keine "\", keine "//", etc.]
      NAS-Benutzername: NAS [muss identisch sein mit dem Freigabenamen, sonst geht gar nix]
      NAS-Passwort: <leer> [ich habe in der Fritz!Box --> Heimnetzwerk --> Speicher (NAS) --> Kennwortschutz abgeschaltet, andere haben da auch schon Schwierigkeiten gehabt]
      Wake on LAN für NAS: <nicht angekreuzt> [Fritz!Box läuft eh immer]
      NAS MAC-Adresse: <leer> [nur relevant für Wake on LAN]
      Port: <leer> [nur relevant für Wake on LAN]
      Danach den UFS-922 in Standby schalten (stromlos ist nicht nötig). Nun sollte im UFS-922 EPG als mögliches Aufnahmeziel das '/mnt/cifs/0' erscheinen, wenn man eine Aufnahme programmiert und bei "Ziel: Aufnahme-Archiv<ok>" drückt. Beim ersten Mal dauert das immer etwas länger und erscheint als grau, ist aber ok.
      Jetzt würde der UFS-922 aber direkt in das Fritz!Box NAS home Verzeichnis '\\fritz.box\NAS\' aufzeichnen, also seinen Verzeichnisbaum unter '\\fritz.box\NAS\kathrein\records' anlegen. Das landet auf der Fritz!Box im internen 10MB Flash Speicher und ist damit natürlich gänzlich ungeeignet. Hängt man eine USB-Platte an die Fritz!Box, so wird die in der NAS-Freigabe unter "\\fritz.box\NAS\<Plattentyp>' sichtbar (bei mir '\\fritz.box\NAS\SAMSUNG-HD103UI-01'). Also, sind noch ein paar weitere Schritte nötig, um auf der Fritz!Box die Verzeichnisse umzu-mounten. Mit meiner Fritz!Box 7270 (54.05.05) hat es durch Konfiguration auf Fritz!Box funktioniert:
      1. an der Fritz!Box telnetnd (Telnet-Service) einschalten in dem man am Telefon #96*7* wählt
      2. mit telnet oder SSH (z.B. putty) als root anmelden, Passwort ist das, was man für das Fritz!Box Web-Interface vergeben hat
      3. [optional] mit "# mount" prüfen, welche Filesysteme gemounted sind, typischerweise wird die USB-Platte unter '/var/media/ftp/<Plattentyp>' gemounted
      4. mit "# mkdir /var/media/ftp/kathrein" ein neues Leerverzeichnis als mounting point anlegen. Wenn man vorher schon den UFS-922 konfiguriert hat, gibt es das Verzeichnis schon, es ist aber nicht leer. Dann ggf. im Browser in '\\fritz.box\NAS\kathrein\' Verzeichnis alle Dateien und Ordner löschen.
      5. mit "# mount -o move /var/media/ftp/<Plattentyp> /var/media/ftp/kathrein"
      Leider ist jetzt nach jeden reboot der Fritz!Box diese Einstellung wieder weg. Angeblich kann man in der Datei '/var/flash/debug.cfg' die Befehle eintragen, so dass sie nach jedem Booten ausgeführt werden. Leider ist es mir noch nicht gelungen, diese Datei zu editieren ("not a regular file"). Bin für jeden Tipp dankbar, werde mich aber auch nochmals bei AVM erkundigen.
      Die Aufnahme des UFS-922 auf die USB-Festplatte des Fritz!Box NAS funktioniert jedoch einwandfrei.
      :hi
      Hallo crazystone

      Danke für die Ausführliche Antwort. Bezüglich dem Passwort: Wenn Du in der Fritzbox das Passwort aktiviert hast, dann musst Du unter dem Benutzernamen ftpuser eintragen und natürlich das Passwort angeben, dann läuft es.
      Was ich noch mache; ich habe zwei USB Speicher angeschlossen, einer für Daten und einer für Filme. In den Receiver binde ich dann nur den mit Filmen ein. Welcher name das ist, kann man aus der Konfiguration von Fritz heraus lesen (Heimnetzwerk --> Speicher (NAS) im Abschnitt Speicher an der Fritzbox). Mein Freigabeorder heisst somit fritz.box/Storage-01

      Gruss

      jack_uf
      Hallo nochmal,

      danke jack_uf für Deine Hinweise. Hast Du dann im Netzwerk-Interface Benutzer IP und Freigabe-Name "fritz.box/Storage-01" eingetragen und beim NAS-Benutzer "ftpuser"? Und das hat funktioniert (also im EPG Aufnahmeziel die "/mnt/cifs/0")? Was hast du für eine UFS-922 SW?


      Ich schiebe gerade Frust und falle vom Fritz!Box Glauben ab. Tatsächlich ist die Fritz!NAS viel zu langsam, um HD-Inhalte (ARD HD, ZDF HD) aufzuzeichnen *heul*. Die erzeugten *.ts Files sind schon bei der Aufzeichnung beschädigt. Ist auch kein Wunder, die von Optimisten gemessenen 4MB/s reichen sind da schon theoretisch knapp. Praktisch sah es bei mir eher nach 2MB/s aus. Überlege jetzt doch noch einen anderen SW-NAS auf einem PC zu installieren.

      SD-Senderaufzeichnung ging allerdings problemlos und auch die Erkennung und Wiedergabe über WMP hat einfach und reibungslos funktioniert.

      Viele Grüße
      crazystone
      Hallo

      Ja, die Daten habe ich so eingegeben. Meine Software-Version ist 2.03.

      Vom Fritz "Glauben" bin ich noch nicht abgefallen. Soweit ich weiss werden bei einem HD Film schon sehr viele Daten produziert. Ich bin z.B. nicht einmal sicher ob mein USB Stick überhaupt so viele Daten verarbeiten kann. Wer nun der Böse ist, ist mir unklar. Wenn ich einmal etwas mehr Zeit habe versuche ich es einmal mit dem Synology NAS.
      Nebenbei bemerkt. Mein alter Notebook kann HD Filme nicht einmal vom Receiver streamen.

      Was ich toll finden würde ist, wenn man die Datenraten bei der Aufzeichnung definieren könnte, oder noch besser, der Receiver automatisch merkt wie viele Daten er ablegen kann. Kenn jemand eine solche Einstellungsmöglichkeit?

      Gruss
      Guten Abend zusammen,

      hab ne UFS922 mit 2.10, und ne Fritzbox mit 6.03
      Nach der Anleitung hier im Forum war ich nicht in der Lage, die Freigabe der Fritzbox von der Kathi aus zu mounten.

      Um der Sache auf den Grund zu gehen, habe ich von Ubuntu 14.04 aus die Fritzfreigabe gemountet:
      sudo mount -t cifs //192.168.178.6/FBF7390-IP6 /mnt/fbf7390 -o user=ufs922,password=lalilu
      und siehe da, df sagt:
      //192.168.178.6/FBF7390-IP6 199239584 78979680 120259904 40% /mnt/fbf7390

      Daraus schliesse ich, daß die Fritzboxfreigabe korrekt eingerichtet ist. Der gleiche Befehl auf der Kathi liefert mir:

      mount: Mounting //192.168.178.6/FBF7390-IP6 on /mnt/cifs/0 failed: Invalid argument

      Was mache ich verkehrt?

      Brgds DerBusIsVoll

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „DerBusIsVoll“ ()

      Danke für die schnelle Antwort.

      Gleiches Ergebnis für Fritzbox FW 6.20.
      Hmmmm, Ich habe zwei 7390 mit jeweils zwei USB Platten seit Jahren in Betrieb, die streamen an XBMC-Clienten.
      Ob das unvernünftig ist? Es funktioniert.

      Und dann verstehe ich nicht, warum die Fritzbox mit Ubuntu funktioniert, mit der Kathi aber nicht. Also wirds wohl nicht an der Fritte liegen.

      Kennt jemand die korrekte Befehlszeile für SMB mounts für die Kathi?

      Brgds DerBusIsVoll
      Aha, jetzt kommen wir der Sache näher. Die 7490 würde also dies "Jumbo-Frames" unterstützen?

      Ich hab mal auf der Kathi ufs922 und der Fritzbox 7390 nachgeschaut, ifconfig gibt jeweils aus:

      Kathi:
      / # ifconfig
      eth0 Link encap:Ethernet HWaddr 00:D0:55:04:CB:D6
      inet addr:192.168.178.44 Bcast:192.168.178.255 Mask:255.255.255.0
      UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
      RX packets:87312 errors:0 dropped:0 overruns:0 frame:0
      TX packets:118047 errors:22 dropped:0 overruns:22 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:12559775 (11.9 MiB) TX bytes:164346210 (156.7 MiB)
      Interrupt:133

      FritzBox:
      eth0 Link encap:Ethernet HWaddr 9C:C7:A6:27:5C:19
      UP BROADCAST RUNNING ALLMULTI MULTICAST MTU:1500 Metric:1
      RX packets:23940134 errors:0 dropped:0 overruns:0 frame:0
      TX packets:19534386 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:128
      RX bytes:721498021 (688.0 MiB) TX bytes:627799582 (598.7 MiB)

      Beide geben mir ein MTU von 1500. Und das sollten dann doch keine Jumbo Frames sein - oder?

      Brgds DerBusIsVoll

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „DerBusIsVoll“ ()

      Beide geben mir ein MTU von 1500. Und das sollten dann doch keine Jumbo Frames sein - oder?
      Der 922 benutzt normal 9000 statt 1500, wenn Kompatibilität gemeldet wird. Mit 1500 beherrscht der 922 HD Streaming nicht.
      UFS 922 DiSEqC 4 Satelliten, keine HD+ oder CI+ Receiver, die haben Restriktionen anstelle von Möglichkeiten !
      Guten Morgen,

      ich fasse mal das Gelernte zusammen:
      1. Das Mounten von cifs shares auf der Fritzbox funktioniert, sowohl unter FritzOS 6.03 als auch 6.20.
        Am einfachsten kann man das testen, indem man in den /app/app Ordner geht und mittels mount.cifs experimentiert. Wenn alles funktioniert, kann man die Eingaben mittels Web-Interface permanent machen.
      2. Nach meinen Erfahrungen darf der Freigabename kein "-" enthalten, darum hat es bei mir zunächst nicht funktioniert.
      3. Zusätzliche Freigaben können im FritzOs in die /var/tmp/samba/lib/smb.config Datei eingetragen werden, mit den gewünschten Pfaden. Diese Änderungen können auch Neustarts und USB An- und Abstecken überstehen, mittels geeigneter Einträge in die /var/flash/debug.cfg. Unter 6.20 ff muss man einen Weg über calllog wählen.
      4. Da die Performance nicht für HD-Aufnahmen ausreicht, nutze ich momentan die Fritz Shares zum Kopieren der Aufnahmen, und dann zum Abspielen im Netzwerk mittels XBMC.
      5. Zugriff auf die Aufnahmen der UFS922 mittels uPnP in XBMC (Kodi 14.1) funktioniert bei mir leider nicht, die .ts Dateien werden nicht abgespielt. Der direkte Zugriff auf die Aufnahme über das Fritz-NAS funktioniert aber! Falls jemand für uPnP XBMC eine Lösung hat....
      6. Zugriff auf die Livestreams der UFS922 mittels XBMC PVR IPTV Simple Client funktioniert gut, hab aber noch Probleme mit dem EPG, und die Aufnahmesteuerung hab ich noch garnicht angefasst. Auch hier wäre ich für eine bessere Lösung dankbar.
      7. Samba Server: Hat jemand die Binaries für die UFS922 erstellt? Welche Erfahrungen gibt es, einen einfachen Sambaserver auf der Kathi unter der Original-Software zu starten?
      Brgds DerBusIsVoll

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „DerBusIsVoll“ ()

      Guten Abend,

      habe mich jetzt mal nach Alternativen umgesehen. Auf der UFS922 ist nun TitanNIT v1.62 installiert.
      Die obigen Punkte 1-4 treffen auch hier zu, und sind als gelöst zu sehen.
      Punkt 5 funktioniert auch unter Titan nicht.
      Punkt 6 ist nun mittels Enigma 2 PVR in XBMC fast gelöst, Streamen, EPG, und Aufnahmen gehen, wenn auch mit sporadischen Problemen.
      7. Den Samba Server habe ich unter Titan am Laufen, also werde ich wohl erst mal bei dieser Firmware bleiben.

      Brgds DerBusIsVoll